Knitter's Review Forums
  The online community for readers of Knitter's Review.
  This week: Always know how much yarn you need
   > Have you subscribed yet?
Knitter's Review Forums
KR Home | My Profile | Register | Active Topics | Private Messages | Search | FAQ | Want to make Betty happy?
 All Forums
 Knitting Machine Talk
 Standard Gauge Machines
 Brother linker not working

Note: You must be registered in order to post a reply.
To register, click here. Registration is FREE!

Screensize:
UserName:
Password:
Format Mode:
Format: BoldItalicizedUnderlineStrikethrough Align LeftCenteredAlign Right Horizontal Rule Insert HyperlinkInsert Email Insert CodeInsert QuoteInsert List
   
Message:

* HTML is OFF
* Forum Code is ON
Smilies
Smile [:)] Big Smile [:D] Cool [8D] Blush [:I]
Tongue [:P] Evil [):] Wink [;)] Clown [:o)]
Black Eye [B)] Eight Ball [8] Frown [:(] Shy [8)]
Shocked [:0] Angry [:(!] Dead [xx(] Sleepy [|)]
Kisses [:X] Approve [^] Disapprove [V] Question [?]

 
   

T O P I C    R E V I E W
chiral Posted - 07/26/2008 : 8:23:52 PM
I have just bought a linker for my brother 910 off eBay. Everything seems to be working on it, I gave it a light oil. The problem is that it won't advance from needle to needle. It just sits in the same spot. Any ideas?

Steve

Steve
7   L A T E S T    R E P L I E S    (Newest First)
chiral Posted - 03/10/2010 : 9:36:56 PM
On my linker the little metal bar at the back (when it's on the machine) was frozen. A little strategically placed oil and it's fine.

The jamming may mean that the linker hook is going under the metal finger instead of over it (when it's on the machine). A slight nudge downward on the bar VERY GENTLY fixed this for me. The finger is to hold the stitch in place while the hook moves and is not for opening/closing the latch.

I have a linker for my Knitmaster (Singer here in Australia) and it's temperamental too. I think it's something linkers are meant to be.

Hope this helps someone.

Steve
http://www.flickr.com/photos/chiral1/
phlame Posted - 01/25/2010 : 10:10:45 AM
I have to say that I think Linkers are very temperamental. I have one and every time I use it I have some kind of problem. Sometime it works and sometimes it doesn't. I just fiddle with it and if I can't get it to work, I do something else.

Shirley, Dana Point, CA

...To much is not enough!
wrapaholic Posted - 01/25/2010 : 03:05:07 AM
Well, I tried my linker again - and it still dropped a lot of stitches and got jammed.

I fear my linker simply does not like me - it seems to be in good working order.....

I have bought another one off ebay - and will try that one - if it also has problems - I will know it is "user error" rather than "linker error"...... the 2nd one off ebay has also been cleaned and oiled and checked - does not appear to have any technical problems.

I'll report back again.

Is there anyone here who has successfully used a linker - ever?!!!

I'm a self-taught machine knitter who is muddling along and enjoying the hobby! I also hand-knit a little (slowly)
wrapaholic Posted - 01/19/2010 : 04:45:21 AM
I'm so glad to have found this thread - I also have a linker that was not working too smoothly - and it was dropping stitches some of the time - so could not reliably be used.
I was beginning to wonder if the latch on the hook was broken because it seemed sprung - I thought it was bent slightly - so it's a relief to know it IS a sprung latch!
I have used some surgical spirit on a cotton bud to clean old lubricant off the linkers undercarriage - and have re-oiled it - it's a lot less lumpy in the movement now - I will report back later when I've used it to tell if it's linking all stitches successfully now!
The other thing that might have been affecting it's use - was that my machine needed a service - I didn't realise this until after I did it - but when I put the new sponge bar in and saw how flat to the needle bed the needles were pressed - well - that showed me!
Everyone else with a linker - you have to do the last row on the loosest tension 10. . before you link!
Happy linking - remember - clean and oil your linker and if necessary (especially if you have a 2nd hand machine) service it and add a new sponge bar!

<font size="6"><font color="violet"><center>Knit-wit!</center></font id="violet"></font id="size6">
MarilynW123 Posted - 10/21/2009 : 11:02:48 AM
Hi,

I realise this is an old thread, but I have exactly this problem.

I have taken the top off the linker, but don't really know what bit makes it move so don't know which bit to clean!

Any information would be gratefully received.

Thanks,

Marilyn
chiral Posted - 04/12/2009 : 9:25:51 PM
I suspect there may be a part of the linker missing from the front of the linker. I gather that these can be broken off fairly easily.

I have a linker for my Knitmaster machine which I have no hassles with, but the mechanism for moving the carriage from one needle to the next is at the back of the carriage and less susceptible to knocks.

Steve
http://www.flickr.com/photos/chiral1/
stove0852 Posted - 09/15/2008 : 3:31:32 PM
Steve, the problem as I'm sure you know is the lube Brother used when they made these linkers. The lube over time turns into a substance more akin to glue than a lubricant. The only cure is to take the top off the linker and clean it thoroughly. There are three places to look to check for a problem. If you look at the bottom of the linker with the needle towards you there is a arm with a sharp point to the upper left corner. This arm must move back and forth. The needle must also move and there is a needle channel to the right side of the linker, inside and to the left of this channel opening you will see a small cut out with a silver piece of metal in it. This piece must also move.
You will need to remove the top of the linker to get at these (and other) areas. To do this remove the knob on top and three screws on the underside. After removing the top clean as much of the gunk off as possible, it may be necessary to remove the disk that the knob was attached to in order to get everything cleaned out. There's a small circlip on the top that has to be removed to do this.
I hope this is of some help...if not let me know through e-mail and I'll try to send you some pictures that might be of more assistance.
Steve (same first name no less)

Steve

Knitter's Review Forums © 2001-2014 Knitter's Review Go To Top Of Page
This page was generated in 0.14 seconds. Snitz Forums 2000
line This week's bandwidth
kindly brought to you by


and by knitters like you.
How can I sponsor?


line subscribe to Knitter's Reviwe